vérifier si votre site est bien indexé sur google
24 juin 2019
Show all

windev modifier ou supprimer un enregistrement à partir d’un requête

la modification ou suppression d’un enregistrement à partir d’un requête et facile grâce à ces deux code :

pour la modification utiliser ce code dans la bouton modifier :

SI TableSelect(TABLE_REQ_consultation) = -1 ALORS RETOUR
sss est un entier = COL_IDClient[TableSelect(TABLE_REQ_SansNom1)]
HLitRecherche(Client, IDClient,sss)
SI HTrouve() ALORS

Ouvre(FEN_Fiche_Client)
TableAffiche(TABLE_REQ_SansNom1)

FIN

pour la suppression utiliser ce code dans la bouton supprimer :

SI TableSelect(TABLE_REQ_LISTE_RDV) = -1 ALORS RETOUR

//1 : &Supprimer
//2 : &Ne pas supprimer
SELON Dialogue(“Êtes-vous sûr de vouloir supprimer l’enregistrement ?”)
// &Supprimer
CAS 1

RDV est un entier = COL_id[TableSelect(TABLE_REQ_LISTE_RDV)]
HLitRecherche(RDV, IDRDV,RDV)
SI HTrouve()
HSupprime(RDV)
TableSupprime(TABLE_REQ_LISTE_RDV)
FIN

// &Ne pas supprimer
CAS 2

FIN

 

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *